Feature #504

disable the feature that shows titlebars temporarily when the menu is shown in dashboard mode and admin console is not connected

Added by david percy about 6 years ago. Updated almost 6 years ago.

Status:ResolvedStart date:09/08/2011
Priority:HighDue date:
Assignee:Andy Dufilie% Done:

0%

Category:Visualization Interface
Target version:1.0
Complexity:Low OIC Priority:
Required by:

Description

use case: we want all controls turned off except the ability to print.

to duplicate: enable dashboard mode, and turn off all menus except Export.

result is that when mouse is moved over the transition from menu bar to chart, the chart control is suddenly exposed. if you keep moving it goes away, and is just visually disturbing.

but if you hover, you can get into the Wrench icon, and all sorts of crazy stuff that we don't want exposed...

here's an example:
http://portlandpulse.org/node/36

History

#1 Updated by Kyle Monico about 6 years ago

You could disable the entire menu because you can access the "Print or Export Application Screenshot" menu item through the right click context menu (the item is just called "Print Application Screenshot").

You can also go into Session > User Interface Preferences > Appearance > Uncheck "Enable tool controls" to disable the wrench icon for every tool (this will leave up the window buttons, meaning a user could still minimize, restore, or close the panel). This option was added into Weave about a month ago (the sessioned value is "enableToolControls" inside WeaveProperties).

Does this resolve the issue for you?

#2 Updated by Andy Dufilie about 6 years ago

  • Tracker changed from Bug to Feature
  • Status changed from Open to In Progress
  • Assignee set to Andy Dufilie

This is not a bug because it was specifically coded to display the title of a window when a menu is shown and it is hovered over in dashboard mode, but since this feature was never requested by a consortium member, I will change it to only behave like that when editable=true is set in the URL or the admin console is connected.

#3 Updated by Andy Dufilie about 6 years ago

  • Subject changed from in dashboard mode, having a menu exposes controls to disable the feature that shows titlebars temporarily when the menu is shown in dashboard mode and admin console is not connected

#4 Updated by Andy Dufilie about 6 years ago

  • Status changed from In Progress to Resolved
  • Complexity set to Low

#5 Updated by Andy Dufilie almost 6 years ago

  • Target version set to 1.0

Also available in: Atom PDF