Feature #433

Add right-click menu option to export a CSV from a DataTableTool

Added by Mike Smyser about 6 years ago. Updated almost 6 years ago.

Status:ResolvedStart date:08/31/2011
Priority:NormalDue date:
Assignee:Kyle Monico% Done:

100%

Category:Visualization Interface
Target version:1.0
Complexity:Low OIC Priority:
Required by:

Description

Currently you can only export an image of the data table from the right-click menu. It would be better the user is able to export a CSV from the right-click menu.


Subtasks

Bug #493: DataTableTool right-click export CSV feature doesn't work right when multiple DataTableTools existResolvedKyle Monico

History

#1 Updated by Andy Dufilie about 6 years ago

  • Category set to Visualization Interface
  • Status changed from Open to Awaiting Feedback

You can already do this through the control panel. Is there something missing from the existing feature that you need?

#2 Updated by Mike Smyser about 6 years ago

Although you can export in the control panel, a user who sees the visualization in Dashboard mode will not have access to the control panel. Therefore, would like the csv-export option added to the right-click menu.

#3 Updated by Andy Dufilie about 6 years ago

  • Subject changed from Ability to export all data from DataTable visualization to csv file to Add right-click menu option to export a CSV from a DataTableTool
  • Description updated (diff)
  • Status changed from Awaiting Feedback to Open
  • Complexity set to Low

#4 Updated by Andy Dufilie about 6 years ago

Right now you can add the export button to the window through an option in the control panel. That way it would be accessible in dashboard mode, though it is not pretty.

#5 Updated by Kyle Monico about 6 years ago

  • Status changed from Open to In Progress
  • Assignee set to Kyle Monico

#6 Updated by Kyle Monico about 6 years ago

  • Status changed from In Progress to Resolved

#7 Updated by Rebecca Lee about 6 years ago

Is this going to be in the menu only when a user right-clicks on a data table, or any tool?

#8 Updated by Andy Dufilie about 6 years ago

This is for the data table tool only.

#9 Updated by Kyle Monico about 6 years ago

  • Status changed from Resolved to In Progress

I just found a possibly large bug or design issue caused by this feature. It should be fixed by Sunday's nightly build. Sorry for the delay.

#10 Updated by Kyle Monico about 6 years ago

  • Status changed from In Progress to Resolved

This should be in the nightly build tonight or tomorrow.

#11 Updated by Andy Dufilie almost 6 years ago

  • Target version set to 1.0

Also available in: Atom PDF