Bug #214

Map visualization zoom slider interface

Added by Georges Grinstein over 6 years ago. Updated about 6 years ago.

Status:ResolvedStart date:07/12/2011
Priority:NormalDue date:
Assignee:Kyle Monico% Done:

100%

Category:Visualization Interface
Target version:1.0
Complexity: OIC Priority:
Required by:

Description

When the obesity demo starts up - the slider triangle shows the largest possible zoom out which is not what the map is showing (about mid zoom around the US).

History

#1 Updated by YenFu Luo over 6 years ago

  • Assignee set to YenFu Luo
  • Start date changed from 07/10/2011 to 07/12/2011

#2 Updated by YenFu Luo over 6 years ago

  • Assignee changed from YenFu Luo to Kyle Monico

#3 Updated by Kyle Monico over 6 years ago

  • Status changed from Open to Resolved
  • % Done changed from 0 to 100

This issue was caused by the fullDataBounds of the visualization being updated after the dataBounds. The MapTool would update the zoomSlider but the fullDataBounds would be undefined, which gave a zoom level of -Infinity. The fix was to add a linkable child of the visualization to which the MapTool would add a callback.

This also fixes a related issue where adding a large layer (WMS) which is larger than the current fullDataBounds would not update the zoomSlider, although the zoomLevel would have changed.

#4 Updated by Andy Dufilie over 6 years ago

The revised fix is to just make the PlotLayerContainer trigger callbacks when the fullDataBounds is updated. (5 lines of code)

#5 Updated by Andy Dufilie about 6 years ago

  • Target version deleted (1.0)

#6 Updated by Andy Dufilie about 6 years ago

  • Target version set to 1.0

Also available in: Atom PDF